Impôts 2013

logo_eid

Personne ne peut passer à côté, malheureusement. Vous avez certainement reçu la fameuse enveloppe brune ou pas (si vous avez coché, l’année dernière, de ne pas la recevoir car vous remplissez en ligne, comme moi).

C’est le temps des cerises, oups…. non, c’est le temps des impôts.

Voici donc la marche à suivre pour installer le lecteur de cartes d’identité sur votre machine basée sur Debian. Personnellement, j’ai réalisé l’installation sur Ubuntu Studio 12.10, et cela fonctionne parfaitement.

Pré-requis

  • Disposer d’un lecteur de carte compatible (préférence type ACR38)
  • Disposer d’une connexion à Internet
  • Disposer des droits d’administrateur de votre machine

Installation

Je vous conseille de passer par le site officiel pour télécharger  les différents paquets en fonction de votre distribution.

http://eid.belgium.be/fr/utiliser_votre_eid/installer_le_logiciel_eid/linux/

Vous devez les télécharger et ensuite les installer dans un ordre précis que nous allons suivre ici.

Pour ma part, j’ai téléchargé :

Le logiciel eID – Ubuntu(64)/Debian(64)

l’eID Viewer – Ubuntu(64)/Debian(64)

Normalement, tout a été installé dans le dossier « Téléchargements » de votre machine.

Dans le Terminal (oui, je sais, j’aime bien passer par là), tapez :

cd Téléchargements

pour accéder au répertoire. Quand vous êtes dedans, tapez un petit ls pour voir si vos paquets sont bien dedans. Voici les noms pour la version 64Bits Ubuntu/Debian:

  • eid-mw_4.0.4r1253_amd64_tcm226-178472.deb
  • eid-viewer_4.0.4r146_amd64_tcm226-178482.deb

Nous allons installer maintenant ces paquets.

Tout d’abord, le eid-mw

sudo dpkg -i eid-mw_4.0.4r1253_amd64_tcm226-178472.deb

Si un message d’erreur arrive vous signalant des mauvaises dépendances, tapez ceci :

sudo apt-get install -f

Ensuite nous allons installer le eid-viewer

sudo dpkg -i eid-viewer_4.0.4r146_amd64_tcm226-178482.deb

Une erreur va certainement arriver en vous signalant le manquement de « JRE »

comme précédemment, tapez :

sudo apt-get install -f

Nous allons passer à l’installation du lecteur de carte proprement dit. Toujours dans le terminal, tapez :

sudo apt-get install libacr38u libacr38ucontrol0

Voilà, votre lecteur de carte est installé et opérationnel. Pour vérifier, dans votre menu, vous allez trouver dans Accessoires  Lecteur de carte eID.

Démarrer le programme, mettez-le en français (si vous voulez), insérez votre carte d’identité et Oh! miracle, toutes les informations de votre carte apparaissent à l’écran.

C’est bien mais, comment fait-on pour encoder par exemple les impôts ? Car maintenant, lorsque l’on va sur le site taxonweb.be, il ne reconnaît pas la carte.

Installation du plugin dans Firefox

Dans votre navigateur Firefox, il faut installer un plugin. Il s’agit de eID Belgique.

Dans la barre d’adresse de votre navigateur, vous pouvez taper directement ceci :

https://addons.mozilla.org/fr/firefox/addon/belgium-eid/

Cela évite de faire la recherche

Cliquez sur Télécharger maintenant, redémarrer Firefox (par l’ordinateur). Maintenant, vous pouvez déclarer vos impôts.

Bonus

Vous souhaitez calculer vos impôts ? Vous pouvez le faire via le simulateur de calculs. Pas besoin de carte d’identité ou autre token. Rendez-vous sur :

http://ccff02.minfin.fgov.be/taxcalc/app/anonymous/public/calcbox/home.do

3 commentaires sur « Impôts 2013 »

  1. Bonsoir,
    Vous avez fait des tests d’installation à partir des sources (gestion des dépendances etc. ) ?

    Car aux dernières nouvelles, le code source était quelque peu en retard sur les version packagé.

    Sinon pour les utilisateur d’ArchLinux j’ai trouvé ceci:
    1) install pcsclite + driver for your cardreader (ccid in my case)
    2) build and install beid-svn from AUR (includes firefox plugin)
    3) start pcscd (and add it to rc.conf, if not running firefox will have a startup delay caused by the plugin)

    pcsclite : http://www.archlinux.org/packages/community/x86_64/pcsclite/
    ccid : http://www.archlinux.org/packages/community/x86_64/ccid/
    beid-svn : http://aur.archlinux.org/packages.php?ID=38653

    (source: https://bbs.archlinux.org/viewtopic.php?pid=956927#p956927 )

    Je n’ai malheureusement pas eu l’occasion de tester.

    Bonne journée.

    J’aime

    1. Malheureusement, je ne travaille qu’avec des bases Debian. Je ne connais pas assez d’utilisateurs d’ArchLinux pour franchir le pas et surtout réaliser les tests pour toutes les plateformes. Pas assez de temps pour cela 😉

      J’aime

Votre commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l’aide de votre compte WordPress.com. Déconnexion /  Changer )

Image Twitter

Vous commentez à l’aide de votre compte Twitter. Déconnexion /  Changer )

Photo Facebook

Vous commentez à l’aide de votre compte Facebook. Déconnexion /  Changer )

Connexion à %s

Créez votre site Web avec WordPress.com
Commencer
%d blogueurs aiment cette page :